May 012010
 

Here are brief list of all NET Framework Installer up-to-date. I would like to keep this list simple, it might come in handy one day.

.NET Framework 4 Standalone Installer


.NET Framework 3.5 Service Pack 1

Notes:

1.1. Supported Architectures
•x86
•x64
•ia64 (Windows Server 2008)

Please ensure that you read IMPORTANT section!

IMPORTANT: After installing the .NET Framework 3.5 SP1 package (either the bootstrapper or the full package) you should immediately install the update KB959209 to address a set of known application compatibility issues.
In addition, on Windows Vista x64 and Windows Server 2008 x64, install the update KB967190 to address a file association issue for XPS documents.


.NET Framework 3.0


.NET Framework 2.0

Required Download:


.NET Framework 1.1


References: